What devices does the WeSpeke Chat app support?

WeSpeke Chat supports all recent iOS and Android devices. We require a minimum of iOS 8.0 or Android 4.1.

Have more questions? Submit a request

Comments

Even more languages on WeSpeke

Powered by Zendesk